Návody

Bezpečnostní release 1.7.8.11 a 8.1.3

Prestashop před verzemi 8.1.3 a 1.7.8.11 vykazuje nedostatky v detekci některých atributů metodou isCleanHTML. Tento problém mohl způsobit zranitelnost cross-site scripting v modulech využívajících tuto metodu.

today
remove_red_eye 2449 zhlédnutí

Prestashop kompatibilita PHP verze

Zde je uvedena tabulka kompatibility PHP verzí pro jednotlivé verze Prestashopu.

today
remove_red_eye 7896 zhlédnutí

Bezpečnostní problém MySQL Smarty cache Prestashop 1.6 - 1.7

V posledních dnech se šíří případy zavirovaných eshopů na platformě Prestashop, způsobené zranitelností, která umožňuje spustit libovolný kód a tím provádět jakékkoliv další změny v souborech a potenciálně odcizit údaje o platební kartě zákazníka.

today
remove_red_eye 4738 zhlédnutí

Spolehlivý hosting pro Prestashop

V článku uvádíme hostingy, které jsou vhodné pro provoz internetového obchodu na Prestashopu.

today
remove_red_eye 4087 zhlédnutí

Přesun reference, EAN kódu a dostupnosti mimo záložku "Detaily produktu"

Od verze Prestashop 1.7, je kód produktu, EAN a počet kusů skladem na produktové stránce dole, na záložce "Detaily produktu". Oproti starším verzím je to celkem nevhodné umístění. Bohužel není možné v našich šablonách tyto údaje přesunout jinam v základní verzi, protože aby se tyto informace překreslovaly při výběru atributu (kombinace), vyžaduje to i úpravy mimo šablonu. 

today
remove_red_eye 1484 zhlédnutí

Zranitelnost u Prestashop modulů

V poslední době se objevilo několik útoků, způsobených bezpečnostní chybou v modulech. Jde o tyto moduly a konkrétně jejich soubory:

today
remove_red_eye 3952 zhlédnutí

Jak přidat Google mapy do detailu objednávky v Prestashopu 1.7

V Prestashopu 1.7 není možnost zadat API klíč pro Google mapy v administraci. Pokud chcete zobrazit Google mapu v detailu objednávky, musíte provést úpravu.

today
remove_red_eye 3816 zhlédnutí

Jak zapnout režim ladění v Prestashopu 1.7

Režim ladění lze zapnout přímo z administrace. Na stránce Nástroje -> Výkon nastavte "Režim ladění" na ANO.

today
remove_red_eye 2033 zhlédnutí

Bezpečnostní problém s PHPUnit

PHPUnit je framework pro psaní jednotkových testů v programovacím jazyce PHP a je používaný i při vývoji Prestashopu. Nástroj slouží jen pro vývoj a neměl by být distribuován s moduly. V některých případech se tak ale stalo (ZIP archivy atd.). Aktuálně je známá bezpečnostní chyba v PHPUnit, která umožňuje útočníkovi spustit PHP kód a tím číst databázi, nahrávat a měnit soubory a instalovat další malware. 

today
remove_red_eye 4853 zhlédnutí

Jak vytvořit odkaz v tpl souboru Prestashop šablony

Ve verzi PrestaShop 1.7 se vytváří URL odkazy novým způsobem. Zde jsou příklady:

today
remove_red_eye 8501 zhlédnutí